Blender 2.93.1 - Exported .glb/.gltf models have no textures

Hi, I've been trying to export different combinations for my custom character created in Blender. It's a simple robot with a principled shader applied using diffuse, roughness, normal, and metallic .PNG textures applied. I've attached images of how it looks on Blender and how it looks when uploaded using "custom character upload" on DeepMotion.
I've tried different combinations:
glb/gltf with path relative "Texture" folder.
glb/gltf with same directory textures (no folder all files are at the same directory level)
Fbx with path relative and root level textures.
None of these combinations worked when uploaded to DeepMotion.
I think this is a bug, since I can upload to https://sandbox.babylonjs.com/
 and the model looks perfect (materials and textures work correctly).
Please let me know how to proceed in order to upload my custom .glb/.gltf model from Blender into DeepMotion with textures.
Thanks!

13replies Oldest first
  • Oldest first
  • Newest first
  • Active threads
  • Popular
  • I also tried the suggested blender material setup

    And I also referenced this video.

     So I know it is not a Blender problem.

    Like 1
  • After re-importing the animation from DeepMotion back to Blender, I see that the VERTEX colors are interpreted inside DeepMotion platform as the "base color". Which is wrong. And you can see that is reflected on the animation of the character while the previewer playback on DeepMotion's site.
    As I mentioned before, I tried to export an .fbx version so all faces will be normalized, and the mesh would be represented correctly. In all of the times I uploaded (7 in total) nor the mesh representation or the material was correct on DeepMotion's site.

    This was the 7th iteration for this character in the platform, making sure I exported all normals facing outwards (no inverted normals), and you can see the results on the second picture. The platform interprets the vertex color as alpha. This is not correct.

    Like
  • There's another issue, some of the faces came back inverted and broken. They do not belong to the same coherent modeled net. Their faces are "near" but not joined. This poses a big problem for editing (or re-editing) materials and part selections.

    Like
  • *** UPDATE ABOUT TRANSPARENT FACES *****
    For all other users reading this, you need to make sure before your export your .GLB file from Blender 2.93.1 to go into the material options and uncheck  "Show backface". Either when reconstructing the material or when exporting, please make sure you have this unchecked.

    Like
  • Thanks for reporting this issue! We will definitely take a look. We are doing some conversions during processing with some third party libraries, and the issue may happen there.

    Meanwhile, just out of curiousirt: why do you use the .glb to upload instead of the .fbx file? Is there some problem with the fbx process?

    Like 1
    • Nicky-DeepMotion I setup the .gltf material according to the Blender material reference page.
      Also, I uploaded the .fbx but it didn't pick up materials or textures either. So I used the .glb approach since (as narrated in the previous message), the file was tested in the babylon.js online website and the .glb file worked as expected showing textures and materials. This is when I isolated something was happening when DeepMotion ingests the .gltf

      Like
    • Pierre Schiller I see. Did you try using the Copy patch mode and lighting up the button beside it when doing FBX export? It is similar to Maya's embed media for fbx export.

      Like
  • Hi Pierre, could you share with us the original glb that you have uploaded? Please send it via email to support@deepmotion.com

    Like 1
  • Hi Pierre, we looked into the issue and here's our findings.

    We are converting glb to fbx in our backend for unified processing, and during this process the fbx converter can not convert the materials for this character correctly. I tried to manually import your glb file into blender and convert to fbx, and it also doesn't have any texture.

    To avoid all the conversion error, I suggest that you treat our result file just as the source of the animation. You can have your source character in the scene, then import the file containing the Animate3D result animation, and copy the animation keyframes back to your source character, which you have already set up the materials and have the good mesh.

    The video attached shows how to do it in Blender:

    1. Have both your original character (not animated) and the Animate3D output animation (may have bad material/mesh) in the scene. As you can see, one character is animated and one is not.

    2. Select the animated character armature. Go to pose mode. Press 'A' to select all the bones.

    3. In the Dope Sheet, select all the keyframes, Ctrl+C to copy.

    4. Switch to Object mode, and select your original character armature (not animated).

    5. Press 'A' to select all the bones. Right click to insert animation on the Whole Character.

    6. In the Dope Sheet, Ctrl+V to paste the animation data. You can then see your original character animated.

    We are sorry for the issues that you've encountered and is very willing to work with you to improve this process. Please let us know how it goes and we will try to make this workflow easier for all the Blender users.

    Like 1
  • Hi. Thank you for your detailed reply.
    I'll send you the file via the email you provided and answer your questions there.

    Kind regards.

    Like
  • Hi Nicky, I've sent a second email to the address you gave me in this thread. Please check them, as I don't know if they are reaching you.

    Thanks!

    Like
    • Pierre Hi Pierre, the emails have reached me, and please don't hesitate to contact me if you have more questions or encountered more problems in the future. We are working on the issues you mentioned and we will keep you updated.

      Thanks again for the great feedback!

      Like 1
  • Thank you for your reply. I am happy to collaborate on these technical issues.

    Like 1
Like1 Follow
  • 1 Likes
  • 3 mths agoLast active
  • 13Replies
  • 152Views
  • 2 Following